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Tutorial 1 — Create and 
Trim Entities
In this tutorial

■ Start AutoSketch

■ Create Simple Entities

■ Create Lines

■ Create Other Simple Entities

■ Trim an Entity
In this tutorial, you learn how to start AutoSketch®, 

create a drawing, and create entities. You also learn how 

to trim entities using several methods. 

More information about each of the concepts in this 

tutorial is available in the Help system.
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Start AutoSketch

In this exercise, you learn to

❒ Start AutoSketch. 
❒ Create a drawing from scratch.

Note At the end of each exercise, you can take a break or move to the next 
exercise. Be sure to save your work at the end of each exercise, because each sub-
sequent exercise builds on the one before it.

To start AutoSketch

1 On the Start menu (Windows), click All Programs (or Programs) ➤ 
Autodesk AutoSketch 10. 

2 In the Tip of the Day dialog box, read the tip and click Close. 

To start a drawing

1 In the Start Up dialog box, Wizard tab, select Start Drawing Immediately. 

2 Click OK. 
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Create Simple Entities 

In the exercises that follow, you become familiar with simple entities by 
creating lines, arcs, circles, polygons, and polylines. While you create enti-
ties, you also become familiar with the AutoSketch drawing window and how 
the menus and toolbars can be used to create entities. In a later tutorial, you 
learn how to create useful drawings with entities and symbols. But for now, 
have fun creating simple entities. 

Create Lines

In this exercise, you learn to

❒ Create a single line, a multiline, and a double line.
❒ Create lines using the Draw menu and the All-In-One toolbar.
❒ Right-click a toolbar button to access related buttons on a toolset.
❒ Right-click a command to end it.
❒ Use the SHIFT key to select multiple entities.
❒ Delete entities.

A line is an entity that connects two points. You can use a line to represent 
any straight object. 

To create a line

1 In AutoSketch, on the File menu, click New. 

2 In the New dialog box, click Start Drawing Immediately, and then click 
OK. 

3 On the Draw menu, click Line ➤ Single. 

4 In the drawing window, click anywhere to create the startpoint of the line. 
Then, click another point in the drawing window to create the endpoint. 
Right-click to end the command.

Example of a line produced with the Line Single option

Click a startpoint Click an endpoint Right-click to end 
LINE command
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You have just created a line, your first computer-drawn entity. Continue 
to draw lines until you feel comfortable with the action. When you are 
ready, you can create a line that has multiple points. 

5 On the Draw menu, click Line ➤ Multiple. 

6 In the drawing window, click anywhere to create the startpoint of the line. 
Then, click another point in the drawing window to create a second line 
point. Continue clicking to create additional points. When you are fin-
ished, right-click to complete the line. 

Example of a line produced with the Line Multiple option

Now, use the All-In-One toolbar to create a line. When you click and hold 
the Line button on the All-In-One toolbar, you see additional buttons 
called toolsets. Hovering over a button displays a tooltip with the name of 
the button. When you end the command, the new button is shown on the 
toolbar. The last button used is what appears on the toolbar, until a new 
button is used. 

7 On the All-In-One toolbar, click and hold the Line button. 

8 On the toolset, drag the pointer until you locate Line Double, and then 
release the mouse button. 

9 Click anywhere in the drawing to create the startpoint of the line. Then, 
click another point in the drawing window to create a second line point. 
Continue clicking to create additional points. When you are finished, 
right-click to complete the line. 

Example of a line produced with the Line Double option

You may want to clean up your drawing at this point so that you have room 
to draw more entities. 
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To delete entities

■ On the keyboard, press CTRL+A to select all entities in the drawing, and 
then press the DELETE key. 

Now that you understand how to create different kinds of lines using the 
Draw menu and the All-In-One toolbar, you can create other entities. 

Create Other Simple Entities

In this exercise, you learn to

❒ Create arcs, circles, polylines, and polygons.
❒ Select startpoints, midpoints, and endpoints.
❒ Use the All-In-One toolbar to create entities. 
❒ Use the All-In-One toolbar to access toolset tools. 

In this exercise, you create variations of an arc, a circle, a polyline, and a 
polygon. 

■ Arc. A segment of a circle defined by a centerpoint, radius, starting angle, 
and included angle.

■ Circle. An entity with a centerpoint and a radius. 
■ Polyline. A multi-segmented line (the segments can be straight or curved). 

Use a polyline to determine the total length of a series of connected 
sgments. 

■ Polygon. A polyline whose startpoints and endpoints are connected 
(closed) to create a shape with multiple sides.

To create an arc

1 On the Draw menu, click Arc ➤ 3 Points. 

2 In the drawing window, click a point to begin the arc, click a second point, 
and then click another point to end the arc. Try this a few times to get 
familiar with it.

Example of an arc produced with the Arc 3 Points option

Click startpoint Click second point Click endpoint
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Now, use the All-In-One toolbar to create a different kind of arc. 

3 On the All-In-One toolbar, click and hold the Arc button. 

4 On the toolset, drag the pointer until you locate 2 Points and Center, and 
then release the mouse button. 

5 In the drawing window, click a point to begin the arc. Click another point 
to mark the second point. Then, click again to mark the centerpoint. 

 

Example of an arc produced with the 2 Points and Center option

Tip The status bar, in the lower-left corner of the drawing window, displays 
prompts that describe the next step in a procedure. If you’re unsure what the 
next step is, look at the status bar for prompts. 

6 When you finish working with arcs, delete the entities. 

To create a circle

1 On the Draw menu, click Circle ➤ Center, Side. 

2 In the drawing window, click a point to set the center of the circle, and 
then drag the pointer out from the center until the circle is the size you 
want. Then, click at that point to complete the circle. Try this a few times 
to get familiar with it. 

Example of a circle produced with the Center, Side option

Click startpoint Click second point Click centerpoint

Click a point Drag pointer 
outward

Click to complete 
circle
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3 On the All-In-One toolbar, click and hold the Circle button, and on the 
toolset, click any of the Circle buttons. Create new circles in your drawing. 

4 When you finish working with circles, delete the entities. 

To create a polyline

1 On the All-In-One toolbar, click and hold the Polyline button.

2 On the toolset, drag the pointer until you locate Single Polyline, and then 
release the mouse button. 

3 In the drawing window, click a point to begin the polyline, and then click 
two more points to create a polyline that is shaped like the letter “V”. 
When you have created your polyline, right-click twice to complete the 
line and end the polyline command. Try this a few times to get familiar 
with it. 

Example of a polyline produced with the Single Polyline option

4 On the All-In-One toolbar, click and hold the Polyline button, and on the 
toolset, click any of the Polyline buttons. Experiment with the different 
kinds of polylines you can create. 

5 When you finish working with polylines, delete the entities. 

To create a polygon

1 On the All-In-One toolbar, click the Polygon button.

2 On the toolset, drag the pointer until you locate Rectangle, and then 
release the mouse button. 

3 In the drawing window, click a point to begin the rectangle, and then click 
another point to end the rectangle. 

Example of a polygon produced with the Rectangle option
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4 On the All-In-One toolbar, click and hold the Polygon button, and on the 
toolset, click any of the Polygon buttons. Create new polygons in your 
drawing. 

When you finish working with polygons, close the drawing.

5 On the File menu, click Close. In the Save Changes to Drawing message, 
click No. 

Trim an Entity

In this exercise, you learn to

❒ Shorten and lengthen an entity.
❒ Create rounded and beveled corners.
❒ Break apart and divide an entity.

Trimming allows you to shorten and lengthen entities so they can meet at a 
specific point to create rounded and beveled corners, or to break apart and 
divide entities.

To trim an entity

1 In AutoSketch, on the File menu, click Open. 

2 In the Open Drawing File dialog box, navigate to the following location: 

C:\Program Files\Autodesk\AutoSketch10\Drawings

3 In the list of files, select Trim.skf, and then click Open. 

The following drawing is opened in AutoSketch.
8 | Tutorial 1 — Create and Trim Entities



First, join two perpendicular lines to create an intersection. 

4 On the All-In-One toolbar, click Trim Corner. 

5 In the Trim Corner 1 section of the drawing, click the horizontal line. 
Then, click the vertical line to the right of that horizontal line. Right-click 
to end the command. 

Example of two perpendicular lines joining to form a corner

Next, use the same Trim Corner button to remove excess lines and form a 
corner. 

6 On the All-In-One toolbar, click Trim Corner. 

7 In the Trim Corner 2 section of the drawing, click the left side of the hor-
izontal line. Then, click the lower part of the vertical line. Right-click to 
end the command. 

Trim Corner 1 Trim Corner 2 Trim Round

Trim Bevel Trim Edge Trim Break

first selection second selection result
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Example of two intersecting lines trimmed to form a corner

Now, create a rounded corner. 

8 On the All-In-One toolbar, click and hold the Trim Corner button.

9 On the toolset, drag the pointer to select Trim Round. 

10 In the drawing, locate Trim Round, in the upper-right section of the 
drawing. 

11 In the Trim Round section of the drawing, click the horizontal line. Then, 
click the vertical line to the right of that horizontal line. Right-click to end 
the command. 

Example of two perpendicular lines joining to form a rounded corner

Next, create a beveled corner. 

12 On the All-In-One toolbar, click and hold the Trim Round button.

13 On the toolset, drag the pointer to select Trim Bevel. 

14 In the Trim Bevel section of the drawing, click the horizontal line. Then, 
click the vertical line to the right of that horizontal line. Right-click to end 
the command. 

Example of two perpendicular lines joining to form a beveled corner

first selection second selection result

first selection second selection result

first selection second selection result
10 | Tutorial 1 — Create and Trim Entities



Next, join two divided lines and then trim the extraneous lines in an 
intersection. 

15 On the All-In-One toolbar, click and hold the Trim Bevel button.

16 On the toolset, drag the pointer to select Trim Edge. 

17 In the Trim Edge section of the drawing, do the following, in order: 

■ Click the left part of the horizontal line.
■ Click the left vertical line. 
■ Click the right vertical line, just below the diagonal line.
■ Click the diagonal line just to the right of the vertical line that you just 

selected. 

Your drawing should match the last picture in the following sequence of 
illustrations. 

Example of two divided perpendicular lines joined and extraneous lines trimmed

click horizontal line click left vertical line click right vertical line

click diagonal line result
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Next, create a break in a line. 

18 On the All-In-One toolbar, click and hold the Trim Edge button.

19 On the toolset, drag the pointer to select Trim Break.

20 In the Trim Break section of the drawing, click anywhere on the horizontal 
line. Then, move the pointer to the center of the line, and click to create 
the break point. Right-click to end the command. 

Example of a line broken into two equal sections

21 On the File menu, click Close. 

22 In the Save Changes to Drawing message, click No. 

Now that you understand how to create different kinds of entities using the 
Draw menu and the All-In-One toolbar, and how to trim entities, you can 
move on to more challenging exercises. 

first selection second selection result
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